nortonham but am not having any luck installing packages.
My issue right now is networking
So, you're held back from installing software because of no connection?
What does:
$ dladm show-link
And:
$ kstat -c net | grep net
Return?
VirtualBox by default configures an emulated Intel E1000E Gigabit Ethernet NIC (not bridged), which is perfectly compatible with illumos and should be autoconfigured by NWAM upon boot.
It should show up like that:
$ dladm show-phys
LINK MEDIA STATE SPEED DUPLEX DEVICE
e1000g0 Ethernet unknown 0 half e1000g0
Verify that the NWAM service in online:
$ svcs -l network/physical:nwam
If you find it in maintenance mode, try to clear and re-enable it:
$ svcadm clear network/physical:nwam
$ svcadm enable network/physical:nwam
Then configure the Ethernet NIC as a DHCP client:
$ ipadm create-if e1000g0
$ ipadm create-addr -T dhcp e1000g0/v4
$ ipadm show-addr
ADDROBJ TYPE STATE ADDR
lo0/v4 static ok 127.0.0.1/8
e1000g0/v4 dhcp ok 10.0.2.15/24
Or assign it a static IP:
$ svcadm disaable network/physical:nwam
$ svcadm enable network/physical:default
$ ipadm create-if e1000g0
$ ipadm create-addr -T static -a 192.168.1.99/24 e1000g0/v4
$ route -p add default 192.168.1.1
(And set up DNS resolution. Put your nameserver into /etc/resolv.conf and configure NSS to read DNS from that file):
$ echo 'nameserver 192.168.1.1' >> /etc/resolv.conf
$ cp /etc/nsswitch.conf{,.bak}
$ cp /etc/nsswitch.{dns,conf}
Disclaimer: I've never done this on VBox (but successfully did it on a NVMM client).
I highly recommend checking out the network-related illumos man pages to become more comfortable with networking on illumos: dladm(8), ipadm(8), route(8), nwamd(8), wpad(8) (for wireless, if needed on real hardware and supported), routeadm(8), flowadm(8).
Also, see Configuring IP Interfaces, among Solaris docs (still relevant).
As you may already know, SVR4 package bundles on Tribblix are installed using zap
, with zap install-overlay
.
I suggest considering using pkgsrc instead (as an alternative, side-by-side with a stand-alone prefix, or in a zone).
For this purpose have a look at:
You can also get more software by converting IPS packages for OI/OmniOS from OpenCSW, using the ips2svr4 utility found on Tribblix github repo.