On a fresh install of OpenBSD 7.2:
- native pf.conf!
- create my first user:
# pdbedit -a -u myuser
- add a share named 'share' on smb.conf — just for test:
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Weak crypto is allowed
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions
# Global parameters
[global]
dns proxy = No
log file = /var/log/samba/smbd.%m
max log size = 50
server role = standalone server
server string = Samba Server
idmap config * : backend = tdb
[homes]
browseable = No
comment = Home Directories
read only = No
[share]
guest ok = Yes
path = /mnt/nas/share
[printers]
browseable = No
comment = All Printers
path = /var/spool/samba
⇒ after starting samba, check process:
$ doas rcctl check samba
smbd(ok)
nmbd(ok)
$ ps auwx | grep mbd
root 21591 0.0 0.0 1352 7636 ?? I 6:58AM 0:00.04 /usr/local/sbin/smbd -D
root 86682 0.0 0.0 1348 3104 ?? S 6:58AM 0:00.01 /usr/local/sbin/smbd -D
root 32738 0.0 0.0 1348 2820 ?? S 6:58AM 0:00.00 /usr/local/sbin/smbd -D
root 73966 0.0 0.0 1408 3300 ?? S 6:58AM 0:00.02 /usr/local/sbin/nmbd -D
myuser 56788 0.0 0.0 512 1484 p0 S+p 6:59AM 0:00.00 grep mbd
⇒ a lookup on lo0, on the server:
$ nmblookup -A 127.0.0.1
Looking up status of 127.0.0.1
NAS <00> - B <ACTIVE>
NAS <03> - B <ACTIVE>
NAS <20> - B <ACTIVE>
WORKGROUP <00> - <GROUP> B <ACTIVE>
WORKGROUP <1e> - <GROUP> B <ACTIVE>
MAC Address = 00-00-00-00-00-00
- same informations on the address IP lan
⇒ rights systems:
$ ls -al /mnt/nas/share/
total 48
drwxr-xr-x 6 root wheel 512 Nov 20 06:54 ../
-rw-r--r-- 1 myuser wheel 2 Nov 20 06:58 test.txt
drwxr-xr-x 2 myuser wheel 512 Nov 20 06:58 ./
- the test.txt file is filled with the number 1
⇒ Try to connect on lo0, on the server:
$ smbclient //127.0.0.1/share -U myuser
Password for [WORKGROUP\myuser]:
session setup failed: NT_STATUS_CONNECTION_DISCONNECTED
$ smbclient //192.168.1.3/share -U myuser
Password for [WORKGROUP\myuser]:
session setup failed: NT_STATUS_CONNECTION_DISCONNECTED
- same result, with the arg '-m SMB3' (or SMB2)…
One idea?