Hello to everyone.
Actually I have two monitors,but usually I use only one of them. The monitor I use everyday with FreeBSD is attached to the HDMI port of the “VGA compatible controller: Intel Corporation CoffeeLake-S GT2 [UHD Graphics 630] (rev 02)” graphic chipset. And it works well. Sometimes,when I want to virtualize Linux,I attach the second screen to the HDMI port of the second GPU I have,the Nvidia Geforce RTX 2080 ti and in this way I can use even the second one. But I don't want to be forced to run bhyve to use the second screen. It could be useful even when I want to make some 3d modelling using Blender on the first one and using the second one to watch some tutorial. Can someone give me some suggestions about how to do that ? I tried to figure it out how to configure everything but it didn’t work. The monitor attached to the nvidia card remained black.
I tried with this xorg.conf :
Section "Device"
Identifier "Card0"
Driver "intel"
BusID "PCI:0:2:0"
EndSection
Section "Device"
Identifier "Card1"
Driver "nvidia"
BusID "PCI:2:0:0"
EndSection
Monitor 1 is attached to the HDMI port of the intel gpu and the monitor 2 is attached to the HDMI port of the nvidia GPU. Does it seems correct ? on FreeBSD I have installed these packages for the gpus :
1) xf86-video-intel-2.99.917.916_1,1 X.Org legacy driver for Intel integrated graphics chipsets
2) nvidia-driver-510.60.02 NVidia graphics card binary drivers for hardware OpenGL rendering
3) nvidia-settings
my /etc/rc.conf looks like this :
kld_list="nvidia-modeset"
my /boot/loader.conf like this :
nvidia_load="YES"
This is what happens after the rebooting :
# kldstat | grep nvidia
3 2 0xffffffff826b6000 2c4e1c0 nvidia.ko
19 1 0xffffffff86031000 fd310 nvidia-modeset.ko
# xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x43 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:Intel
the nvidia card is not detected. But,the utility nvidia-settings shows that the driver detects two screens and that the 2 monitor is attached to the nvidia card. I’ve captured some screenshots and I’ve attached them,hoping that they can be useful to understand whats wrong.
Monitor 2 is turned on and I can see the mouse pointer that can go over it,BUT there is nothing inside of it,it is totally black.
I tried also with this xorg.conf :
Section "Device"
Identifier "Card0"
Driver "intel"
BusID "PCI:0:2:0"
EndSection
Section "Device"
Identifier "Card1"
Driver "modesetting"
BusID "PCI:2:0:0"
EndSection
Using modesetting the monitor does not turn on at all. I forgot to say that on my BIOS I have configured the intel graphic chipset as primary.