I don't give up that easily ? ...
Here's a step-by-step guide that allows streaming Netflix media on NetBSD using a intel-haxm accelarated QEMU vm.
Heads-up! Sound doesn't work, but everything else is fine. Please read the rest of this thread for a solution to this!!
Start by obtaining the sources according to chapter 30 on the NetBSD guide. Actually, you only need to fetch and unpack syssrc.tgz
Set-up pkgsrc if you don't already have it.
cd /usr/pkgsrc/emulators/haxm
sudo make
sudo make install
sudo make clean
sudo make clean-depends
Once done, do update/upgrade your system and install qemu
sudo pkgin update
sudo pkgin full-upgrade
sudo pkgin install qemu
Now create the haxm device nodes
sudo haxm-mknod
and load the modules
sudo haxm-modload
Create a virtual machine with enough space
qemu-img create vm.img 8G
Pick an Ubuntu based distro and boot the live image. I've took Peppermint 7, since I know this image worked for me earlier using qemu-kvm on Linux. Give the machine a rather low RAM, so it doesn't create an unnecessary large swap partition.
sudo qemu-system-x86_64 -boot d -cdrom /path/to/image.iso --accel hax -m 1G -hda vm.img
You will need to pass the noapic option to the Linux kernel at boot time.
Once running, install the system on the virtual machine and shutdown the vm.
Re-launch the vm, this time give it more RAM to work with
sudo qemu-system-x86_64 -boot d --accel hax -m 4G -soundhw hda vm.img
Unfortunately, and as mentioned sound doesn't work yet. The system boots fine but warns that "could not init 'oss' audio driver" - See below the observations of @JuvenalUrbino
Update the packages in the vm, launch Firefox and enable DRM content. Login to Netflix and voilá, streaming Netflix on NetBSD ?
If you want to remove it, start by deleting the vm.img
Then...
sudo haxm-modunload
sudo rm /dev/HAX
sudo rm -r /dev/hax_vm*
sudo pkg_delete haxm
Optionaly, you may remove QEMU and its dependencies using pkgin and remove /usr/src and /usr/pkgsrc to free space on your hard drive.
Enjoy!