Okay, so I've taken out a day or so to go through all this and report my findings. Just before I began writing this, I experienced a fatal breakpoint trap
(see here). Ouch.
That'll do for now so I'll just report on everything I observed or managed to test.
@rvp, I've tried to follow your advice to the best of my abilities but may have overlooked some things, though. I've gathered as much output as I could although some things might be missing. I've tested -HEAD before doing a clean reinstall of 9.2 which has been my main focus.
EDIT: For what it's worth, I just wanted to add that I didn't encrypt any partition this time. I enabled WAPBL as before.
So, here's an overview:
BIOS settings
Checked everything just to be sure. Didn't look into updating so far as I didn't feel like messing with the BIOS since I haven't had any issues running other operating systems.
- Secure boot -> OFF
- I/O settings -> bluetooth switched OFF (never use it)
- Virtualization -> all set
- UEFI boot -> legacy only (as usual)
- System date -> date is fine but I set the clock to UTC (was on localtime)
On the battery issue, I've re-checked but haven't noticed anything wrong with it. Seems just fine to me.
Testing -HEAD
1. Audio & touchpad
Seemed fine at first. I only used the touchpad, no mouse. When switching between TTYs (so not even necessarily while using the touchpad), I suddenly got "static" on audio output and some "reverbing". This eventually disappears but it's annoying when it happens as it's unpredictable.
Just want to note here that this is a machine on which I typically use only the touchpad so I basically expect it to just work or be fairly straightforward to get it to work. I realize now that a lack of two-finger scrolling, which apparently is not currently supported on Synaptics, is a sacrifice I'm not really willing to make on this machine.
2. Networking
I exclusively use wireless on my laptops, never (or rarely) Ethernet, with a static IP. On shutdown, as with 9.2, I get iwm0 fatal firmware error
. Otherwise, though, it connects and appears to be working normally.
3. Performance
Seemed better to me than 9.2 but I focused my attention on 9.2.
4. VIM
Could not install it on -HEAD due to some missing dependency, something I experienced with other packages as well (e.g. libreoffice). But we're focusing on 9.2 here of course. Here's the output:
/usr/lib/libterminfo.so.1, needed by vim-gtk3-8.2.2557nb3 is not present in this system.
40 packages to install:
[...]
0 to refresh, 0 to upgrade, 40 to install
53M to download, 369M to install
the following packages have unmet requirements: vim-gtk3-8.2.2557nb3
4. More output for reference:
- rc.conf
- dmesg
- intcrtl before & after touchpad use
- envstat (xfce + firefox-esr with three loaded websites)
- envstat (xfce upon attempting to change the menu icon)
- top (xfce + firefox-esr with three loaded websites)
- Xorg.log
Testing 9.2
1. Touchpad, audio, etc
Given the issues with the touchpad and audio I reported on earlier, I tried @rvp 's fix with regular X11 and modular Xorg. Unfortunately, it didn't make any significant difference to me.
CPU still running way too hot, particularly when transferring files (e.g. over the network) or when trying to change the XFCE menu icon after installing papirus-icon-theme
. At some point, the CPU temperature went up to 80 °C as you'll see in the pastebins.
2. VIM
@rvp, I tried your suggestion but that didn't work, though I think you'd figured that out and that's why you suggested I build vim from pkgsrc, right? So I went ahead, got the kernel sources, obtained the latest pkgsrc version, and built vim-gtk3
from source.
Unfortunately, no luck. I admit I may of course have overlooked something here. I rarely compile software, I rely on binary packages in 99% of the cases so if I needed to do anything specific, I haven't. In any case, it didnt respect my ~/.vimrc
settings. At least, not the termguicolors
and colorscheme
part. Here's the output I got:
E558: Terminal entry not found in terminfo
'xterm-x256color' not known. Available builtin terminals are:
builtin_gui
builtin_dumb
defaulting to 'ansi'
E437: terminal capability "cm" required
Press ENTER or type command to continue
3. Networking
Wifi generally just works as it did before but file transfers tend to slow down, even on the local network.
- example output after getting an mp3 from the local network with
sftp
:
100% 11MB 696.8KB/s 896.0KB/s
Normally transfer speed would have to be almost twice as much.
- pinging local machines: see here
4. Virtualization
I didn't get around to testing nvmm
this time though I built haxm
from pkgsrc. This time it built fine (I'd filed a bug report on this and it got fixed, thanks for that) but when loading the module, things went haywire and I had to reset my machine (the laptop, that is). No idea what happened. I saved a coredump but I'm not sure where to put that.
4. Output for reference:
rc.conf (see above as it's pretty much the same as on -HEAD)
dmesg
intrctl before and after touchpad use
envstat (xfce, running idle)
envstat (xfce + firefox-esr with 3 websites loaded)
envstat (same as above but with a YouTube video playing)
envstat (xfce, attempting to change menu icon)
envstat (xfce, still attempting to change it and temperature rising...)
envstat (xfce, before I decide to close X11 and end up with the breakpoint trap not long after that)
top (after installing xfce + vlc + firefox-esr + libreoffice with pkgin)
top (xfce, while changing menu icon)
Xorg.log
By way of comparison, this is the output on a T550 running Devuan Linux with virtually identical specs to the X250 (except 16gb RAM and not 8Gb as on the X250). I had the above mentioned issues with NetBSD on that machine, too, so it's not the X250. Should have taken some top
and sysctl
output from OpenBSD or FreeBSD running on the X250 when I had the chance but, alas, I didn't. At any rate, performance was better for me with those.
- top - An ordinary session. Xfce, Firefox with loads of tabs, a vlc video playing, music player running, etc. Nothing unusual.
- sensors - For that same session.
Conclusion
As it stands, I'd rather revisit NetBSD when 10 comes out, since -HEAD did seem to run smoother. I won't be having so much time on my hands in the time to come to (re)install, tinker, test, compile software, and start the process all over again. So if I do want to run a BSD on the X250 while getting the most out of the machine and getting productive, I'm probably better off with OpenBSD for now. But as always, your mileage may vary!
@rvp Thanks a lot for all your input and suggestions, much appreciated
Cheers.