A while ago @Jay asked me to write a follow-up on the 'automounting with Berkeley am-utils' thread, showing how to automount a NTFS partition on NetBSD; actually, this one was pretty straightforward: just did it in the way which anybody would expect it to be done with, and it worked out of the box at first try
I formatted a 128GB SD card to NTFS using mkntfs(8) from filesystems/ntfsprogs.
Let's confirm everything's in place
% gpart -vg /dev/sd0 | less
Guessed primary partition table:
Primary partition(1)
type: 007(0x07)(OS/2 HPFS, NTFS, QNX or Advanced UNIX)
Important preliminary notes
The FUSE ntfs-3g driver is available on -current branch only, not even in 8.0. I have a HEAD installation on a external HDD, so booted it in order to test this
if you have a custom kernel, remember FUSE needs the puff(4) framework to work, so make sure you have:
file-system PUFFS
pseudo-device putter
inside your kernel config
Install ntfs-3g
% cd /usr/pkgsrc/filesystems/fuse-ntfs-3g && make install clean clean-depends
AMD configuration
Update you am-utils multi-device map by adding
ntfs mount:="/usr/pkg/bin/ntfs-3g ntfs-3g \
/dev/sd0e ${fs}"
to your /etc/amd/media map; naturally, replace sd0e with the actual partition to mount; a second SATA HDD with WindowsNT 7+ installed onto would likely occupy the /dev/wd1 wedge node, with NTFS-DATA on the 4th partition (wd1d)
Now you can see it mounted inside my $HOME/media dir as expected (notice usb2 and cd are shown as question marks as they were not found during am-utils scan):