After Qemu, I try Xen.
I never tried Xen before.
So, from the beginning (fresh new complete install, with pkgin, pkgsrc, xdm, ctwm...)
su -
Let's get a better teminal and firefox to publish this topic !
pkgin -y in qterminal firefox wget
Right-clic : Restart CTWM
Then start qterminal and firefox.
su -
cp /usr/pkg/share/examples/rc.d/dbus /etc/rc.d/dbus
echo dbus=YES >> /etc/rc.conf
service dbus start
Fix pkg vulnerabilities db
/usr/pkg/sbin/pkg_admin -K /usr/pkg/pkgdb fetch-pkg-vulnerabilities
The NetBSD's documentation says to build xenkernel and xentools, but I see them already packaged with pkgin...
Don't know what to do...
Let's make first.
Dependencies and runtime for xenkernel415 (I pkgin first, in order to try to speed up the build a little bit - I try on a slow computer (but able to virtualize))
pkgin -y in mktools cwrappers digest bison perl gmake python310
(it's written python311 in the dependencies but the making asks for python310 (?))
Dependencies and runtime for xentools415 :
pkgin -y in python311 py311-setuptools py311-curses dev86 glib2 glib2-tools cmake gsed pkgconf ocaml ocaml-findlib pciutils zstd yajl argp pixman
Let's build : xenkernel415
cd /usr/pkgsrc/sysutils/xenkernel415 && make install clean
Let's build : xentools415
cd /usr/pkgsrc/sysutils/xentools415 && make install clean
Install the kernel at /
cp -p /usr/pkg/xen415-kernel/xen.gz /
Download the dom0 example :
wget ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-9.3/amd64/binary/kernel/netbsd-XEN3_DOM0.gz -P /
Add Xen boot to /boot.cfg :
echo "menu=Xen:load /netbsd-XEN3_DOM0.gz root=wd0a console=pc;multiboot /xen.gz dom0_mem=512M" >> /boot.cfg
echo "menu=Xen single user:load /netbsd-XEN3_DOM0.gz root=wd0a console=pc -s;multiboot /xen.gz dom0_mem=512M" >> /boot.cfg
Put xencommons script to /etc/rc.conf
cp /usr/pkg/share/examples/rc.d/* /etc/rc.d/
echo xencommons=YES >> /etc/rc.conf
Try to boot on Xen :
reboot
Select Xen boot... and 10 seconds after, the computer shuts down.
Tried Xen Single user, same end.
This is the error (took the camera because it disappears very quickly ! :-D
(XEN) Xen version 4.15.4nb0 (root@) ...
...
(XEN) Command line: dom0_mem=512M
(XEN) Xen image load base address: 0
(XEN) Video information:
(XEN) VGA is text mode 80x25, font 8x16
(XEN) VBE/DDC methods: V2; EDID transfer time: ? seconds
(XEN) Disc information:
(XEN) Found 1 MBR signatures
(XEN) Found 1 EDD information structures
(XEN)
(XEN) *********************************************
(XEN) Panic on CPU 0:
(XEN) dom0 kernel not specified. Check bootloader configuration
(XEN) *********************************************
(XEN)
(XEN) Reboot in five seconds..
(in fact it reboots in less than 0.2 seconds ... :-D)
Can someone tell me what's next ?